Chez Ptit Gars

Accueil > Informatique > PirateBox

PirateBox

lundi 7 octobre 2013, par Pti Gars

étape 10 reboot
Le connecter en filaire sur le réseaux local
mettre une IP fixe sur sont PC dans la meme plage que le routeur étape 6
on se connecte en ssh, le mot de passe est celui défni

commande utile
arret piratebox :
/etc/init.d/piratebox stop

192.168.0.66


Voici la marche à suivre pour créer votre piratebox :

Les étapes marquées en commentaires correspondent à celles qui sont écrites ci-dessous.

Préalablement vous devez positionner le bouton se trouvant sur la tranche du routeur en mode WISP.

- Etape 1 : Brancher votre routeur à son alimentation ainsi qu’à votre ordinateur via le câble éthernet fourni (note : si vous possédez le wifi sur votre ordinateur il faut le désactiver).

- Etape 2 : Connectez vous à la page de configuration du routeur avec n’importe quel navigateur en tapant dans le champ URL 192.168.0.254, L’identifiant ainsi que le mot de passe sont admin.

- Etape 3 : Télécharger OpenWrt(version modifiée par Matthias Strubel pour régler les problèmes de kernel). Naviguer à travers le menu jusqu’à FIRMWARE&UPGRADE sélectionnez le fichier Openwrt que vous avez téléchargé précédemment et cliquez sur OK, attendez que le routeur redémarre.

- Etape 4 : Téléchargez PUTTY (choisissez la version qui correspond à votre système), lancez le et effectuez une connexion en telnet en tapant 192.168.1.1 dans la barre nommée Host et cochez telnet (par défaut c’est SSH),

- Etape 5 : Définissez un mot de passe en tapant la commande passwd

- Etape 6 : Editez la configuration du routeur en tapant vi /etc/config/network, (note : pour modifier les lignes tapez i puis éditez normalement pour sauvegarder taper sur la touche ecap puis ZZ), éditez les lignes :

config interface ’loopback’
option ifname ’lo’
option proto ’static’
option ipaddr ’127.0.0.1’
option netmask ’255.0.0.0’

config interface ’lan’
option ifname ’eth0’
option type ’bridge’
option proto ’static’
option ipaddr ’une IP comprise dans la plage de votre box’
option netmask ’255.255.255.0’
option gateway ’IP de votre box’
list dns ’IP de votre box’
list dns ’8.8.8.8’

- Etape 7 : Sauvergardez les paramètres en tapant cette commande :

cp /etc/config/firewall /etc/config/firewall.bak

- Etape 8 : Modifiez les paramètre du pare-feu en tapant cette commande :

vi /etc/config/firewall

- Etape 9 : Modifiez les 23 première lignes comme ceci :

config defaults
option syn_flood ’1’
option input ’ACCEPT’
option output ’ACCEPT’
option forward ’ACCEPT’
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

config zone
option name ’lan’
option network ’lan’
option input ’ACCEPT’
option output ’ACCEPT’
option forward ’ACCEPT’

config zone
option name ’wan’
option network ’wan’
option input ’ACCEPT’
option output ’ACCEPT’
option forward ’ACCEPT’
option masq ’1’
option mtu_fix ’1’

- Etape 10 : Activez le wifi en tapant :

vi /etc/config/wireless

Puis changez la 12e ligne (option disabled 0), changez le 1 par un 0

Assurez vous que votre routeur soit connecté à votre box ou à votre réseau local mais il faut qu’il ai accès à internet et que votre ordinateur soit connecté au même réseau.

- Etape 11 : Connectez vous via PUTTY en renseignant dans le champ host l’IP que vous avez choisi à l’étape 6, le mot de passe est celui que vous avez défini à l’étape 5

- Etape 12 : Les serveurs OpenWRT ont lâché il y a quelques temps de cela ce qui à empêché plusieurs personnes de finir l’installation donc pour plus de sécurité tapez ceci :
vi /etc/opkg.conf
Puis modifiez la ligne pour qu’elle ressembe à ceci :

src/gz attitude_adjustment http://stable.openwrt.piratebox.de/ar71xx/packages

- Etape 13 : Faite un ping pour vous assurer que votre routeur est bien connecté à internet et qu’il n’y a pas de problème de configuration à l’étape 6, pour ce faire tapez :

Pour stoper le ping faite ctrl+c

ping google.com

- Etape 14 : Connectez une clé USB formatée en FAT32 au port USB 3G de votre routeur

- Etape 15 : Installez les packages mkpiratebox incluant le chat en tapant :

cd /tmp
wget http://piratebox.aod-rpg.de/piratebox_0.6.3_all.ipk
opkg update && opkg install piratebox*

Etape(option) : Vous pouvez installer le thème Kareha permettant une personnalisation graphique plus poussée :

/opt/piratebox/bin/install_piratebox.sh /opt/piratebox/conf/piratebox.conf imageboard

Puis configurez la en tapant, pour changer le nom d’utilisateur et le mot de passe ADMIN_PASS et SECRET

vi /opt/piratebox/www/board/config.pl

- Etape 16 : Si tout c’est bien passé PUTTY affiche « Piratebox started, you can remove the WAN connection now », redémarrez votre piratebox en tapant "reboot" dans la fenêtre PUTTY et voilà vous avez votre piratebox.


Voir en ligne : pirateboxfr | Le site des piratebox françaises